Get in touch
Back
Maintenance

Network Upgrade

Completed 9 Oct at 04:00am NZDT.

Reachability Shared Hosting
Completed

Maintenance completed

Posted 9 Oct at 04:00am NZDT.
Started

We are conducting power and network upgrades this evening (Saturday 8th October) between 8pm and 4am. Services may be intermittently unavailable during this time.

Posted 8 Oct at 08:00pm NZDT.